Unable to connect Core

I follow minimum server requirements. All of the nodes are in different server

Hey buddy,

This may be caused due to the restrictions over the network, have you fulfilled all the network pre-requisites mentioned in the below link.


If you are using a proxy environment, then you have to do the installation using the below link, as the proxy must have to be configured over the docker level and on the container level.




No proxy in my environment. Can you please give me any documents so that I can check ports.



I agree with @Barry-allen

Hi @eyamin - Will it be possible for you to provide a snapshot of the browser network activity once you press the “Connect” button. This will help us review breakpoints in route.

Here is a video to help you with the process of investigating network activity.

Inspect Network Activity - Chrome DevTools 101

Hi eyamin,

This may happen if the application is not started properly, Please check the docker-compose logs to check weather the docker container is properly up or not. Use the below commands;

On CO, DN and AD;

$ cd /DNIF
$ docker-compose logs -f

It looks like the wrong IP address has been used, as this verification is failing if you used a different IP address during installation and then used another address when connecting to the core. I suggest install “net-tools” and then check the IP address, use static IP address instead of DHCP address.


Hi all,
I’m having the same issues. My core and console are on the same server. Data node is deployed on a different server. Both servers are on the same subnet. (hence there are no firewall/proxy issues involved) When I try to connect to the core, I’m getting a 502 in chrome
docker-compose logs -f is showing me no errors or logs when I attempt to connect to the core on the same IP as the console.
The only message I can see in docker logs is “CRIT Server ‘unix_http_server’ running without any HTTP authentication checking”

Thank you.

Hey Daniel,

I’m expecting that you have followed the “Minimum requirement” and “Before you begin” to deploy the setup.

All the component servers and your host machine’s date and time must be in sync. I would suggest using a centralized NTP server.

Can you please share the snippets for “docker-compose logs -f” from your CORE server for all the components?

$ cd /DNIF/
$ docker-compose logs -f

$ cd /DNIF/LC/
$ docker-compose logs -f

In addition to this, I have found some interesting information about the 502 Bad Gateway error.



Hi Flash,

Unfortunatley the forum is preventing me from uploading screenshots due to being a “new user”, despite me uploading an image in my earlier post.

Hi Flash,

Please see outputs below.


And apparently only two links in a post :roll_eyes:

Console nginx logs:

Core nginx logs:

Do you know whether there are any other locations I can find logs?

Hey daniel,

Thanks for the snippets, as I have checked the Link and observed the I/O error in the docker-compose logs of the core and after further analyzing, this seems to be an issue with the hard disk links.

It seems that due to this error, the docker container is not started properly, and you are facing the issue while connecting to the CORE.

ERROR: blk_update_request: I/O error, dev fd0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0


Hey Flash,

I have been trying to install the demo but come to an error while connecting to core, when I checked on the docker image the command did not pull the core image so I tried to pull dnif/core manually but it also returned error manifest for dnif/core:latest not found: manifest unknown so can you check it with the dev team.
Kindly find the attachment here in for your reference. I tried to check other available docker images and pulled all available with docker pull dnif/core -a and checked the latest build but it didn’t worked. So my request is kindly fix it first and if possible setup Core and LC in one Ubuntu machine, AD and Datanode in another Ubuntu then use utility like systemback and create system image then convert it as ISO file then share that ISO for light touch install.
When I checked docker images list -a the core has not been found. Then I tried to pull it manually then I get the issue.
I tried pulling all the docker images of core then tried to run latest but it also gave me error and did not started. Then I pulled the core by using docker pull dnif/core:v9.1.0 as well which didn’t worked for me so I did pulled a little old one with docker pull dnif/core:v9.0.7 then started it and finally I got it running but the system has some technical issue like slow system and core connection timeout

I hope this issue will be fixed soon.

1 Like

Hey Sachinjung,

The docker image should not be pulled manually as the correct way to install the DNIF Components is by using the script hence, we would request you to install the DNIF Components by using the script only.

Kindly refer the below link for the DNIF v9.1.0 installation.




Dear Elena,

Maybe you haven’t got my concern let’s breakdown what I did.

  1. I ran the single line script in Ubuntu 20.04 LTS

sudo bash -c “$(curl -s https://raw.githubusercontent.com/dnif/installer/main/install.sh)”

  1. I installed Core option 1 first time (This should pull dnif/core:v9.1.0 image as I think)
  2. I ran the script again and this time I installed LC option 2 (This did pulled the console image)
  3. I checked docker ps and found there is only LC running
  4. I checked the docker images with docker image ls which showed that there is only console image not core

Hardware I used
2 x 8 Core Intel Xeon 2nd Gen Processor
2 x 10G SFP+, 2 x 10G Base-T, 5 x 1G Base-T

Now, tell me what went wrong. Can you record the install process by yourself and share.

Hello Sachinjung,

Please refer to the below video, which will help you in the installation process.


@Flash thanks for the video link.

but when we run script to install core it want ask for IP address as we see in video.

and if i try to pull dnif/core manually it stuck on downloading on random file.

so help me out for the same.


I guess it is getting fusion. You can do one thing remove the existing docker and all folder which has been created by LC and Core and do the fresh installation from the scratch.


Hey @Elena,

i have tried your solution also but still facing same issue.

any other way to get download all the necessary files.


Can you share the snapshots for the below commands.

$ docker ps
$ tail -f /DNIF/install.log

The necessary files has been automatically downloaded after executing the script.


Can I install Core, Console, Datanode, Adapter on a single Ubuntu machine or different VMs

No…feel free to check out a similar thread for reference: First Time UI Failure and Not able to connect with Core